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KEY FINDINGS 

 In our single-tasking tests, four SSDs 
completed four typical Photoshop 
tasks as much as 34 percent faster 
than did four HDDs. (See Figure 1.) 

 In our multi-tasking tests, four SSDs 
completed four typical tasks up to 44 
percent faster than did four HDDs 
when we ran the tasks in the 
foreground while unzipping a file in 
the background. (See Figure 1.) 

 Compared to the single-tasking tests, 
the multi-tasking tests took the SSDs 
approximately 0.6 seconds longer, a 
penalty of only 7 percent, while the 
HDDs took approximately 3.6 
seconds longer, a penalty of 27 
percent. (See Figure 3.) 

 

Executive summary 
Intel Corporation (Intel) commissioned Principled Technologies 
(PT) to compare the performance on visualization tasks of two 
types of disk drives: 
 

 Intel X25-E Extreme SATA solid-state drives (SSDs)  

 Standard 15K RPM SAS hard disk drives (HDDs) 
 
We created a test that included four tasks in Adobe Photoshop 
CS4: opening the Photoshop application, opening an image, 
rotating the image, and saving the modified image as a PSD file.  
 
We tested four Seagate Savvio 15K RPM SAS 73GB hard disk 
drives and four Intel X25-E Extreme SATA 32GB solid-state 
drives. We used a Newisys NDS-2240 enclosure attached to a 
workstation installed with the 32-bit edition of Windows Vista 
Ultimate with SP1 and Microsoft Office 2007 Enterprise Edition on 
internal drives. We installed Adobe Photoshop CS4 on the test 
drives. 
 
Figure 1 shows the performance results for the HDDs and the 
SSDs. These results are the times for the four Photoshop tasks running both on their own (single-tasking) and 
while an unzip task ran in the background (multi-tasking). We report the individual task times and the total time 
for the four tasks. We ran the test three times and report results from the run that produced the median total 
time.  

The four Intel X25-E 
Extreme SATA 32GB 
solid-state drives 
delivered up to 34 
percent faster times in 
the single-tasking tests 
than did the four 
Seagate Savvio 15K 
RPM SAS 73GB hard 
disk drives: 8.9 
seconds total time for 
the SSDs versus 13.5 
seconds total time for 
the HDDs. In the multi-
tasking test, the SSDs 
delivered as much as 
44 percent faster times 
on the same four tasks 
when we ran them 
while we unzipped a 
file in the background. 
In that test, the four 
SSDs finished the 
tasks in approximately 
9.5 seconds versus 
17.1 seconds for the 

     

 
Figure 1: Photoshop performance results in task times for the two storage configurations. Lower 
times are better.  
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HDDs. The SSDs took approximately 0.6 seconds longer to complete the multi-tasking tests, a performance 
penalty of only 7 percent, while the HDDs took 3.6 seconds longer to complete the multi-tasking tests, a 
performance penalty of 27 percent. 

Workload 
We installed Photoshop CS4 on the external drives, along with the following two files that we used during the 
test: 

 119MB Photoshop PSD test file 

 814MB ZIP self-extracting executable 

The single-tasking tests included the following tasks: 

1. Open and close the following programs to simulate normal usage: Microsoft Excel, Microsoft Word, 
Microsoft PowerPoint, Windows Media Player, and Microsoft Outlook. 

2. Extract the ZIP file onto the external drives. 
3. Open Photoshop.  
4. Open the Photoshop test file.  
5. Rotate the Photoshop image 180 degrees.  
6. Save the image to a new PSD file on the external drives.  

The multi-tasking tests included the following tasks: 

1. Extract the ZIP file onto the external drives. 
2. Open Photoshop.  
3. Open the Photoshop test file.  
4. Rotate the Photoshop image 180 degrees.  
5. Save the image to a new PSD file on the external drives.  

For the single-tasking test, we waited until the ZIP file extraction completed before opening Photoshop. For the 
multi-tasking test, we started the Open Photoshop task 15 seconds into the unzip task and completed the four 
Photoshop tasks while the unzip task ran. For both the single-tasking and multi-tasking tests, we timed the 
Photoshop tasks. We also timed the background task for the multi-tasking test.  
 

Test results 
Figure 2 includes the results we show in Figure 1 and the percentage wins for each task. 
 

Photoshop task times 

  Single-tasking Multi-tasking 

 

Four 
Seagate 

Savvio 15K 
SAS HDDs 

Four Intel  
X25-E 

Extreme 
SATA 
SSDs 

Seconds 
win for  
SSDs 

Percentage 
win for 
SSDs 

Four 
Seagate 

Savvio 15K 
SAS HDDs 

Four Intel  
X25-E 

Extreme 
SATA 
SSDs 

Seconds 
win for  
SSDs 

Percentage 
win for 
SSDs 

Open Photoshop   8.72 5.01 3.71 42.5% 11.62 5.33 6.29 54.1% 

Open a large file 
in Photoshop 

  2.02 1.37 0.65 32.2%   2.59 1.50 1.09 42.1% 

Rotate a large file 
180 degrees 

  1.25 1.18 0.07   5.6%   1.44 1.29 0.15 10.4% 

Save a large file 
as a new PSD file 

  1.51 1.37 0.14   9.3%   1.47 1.41 0.06   4.1% 

Total time 13.50 8.90 4.60 33.9% 17.10 9.50 7.60 44.3% 

Figure 2: Individual task times and total task time for the four Photoshop tasks in the single- and multi-tasking tests. Results are      
from the run that produced the median total time. Percentage wins use the following formula: 1-(SSD result/HDD result). 
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The SSDs were faster on all four tasks. They delivered their biggest performance boost in the Open Photoshop 
task, where they were faster than the HDDs by 3.71 seconds in the single-tasking test and 6.29 seconds in the 
multi-tasking test. 

Figure 3 shows a comparison of the times for the single-tasking and multi-tasking versions of the test. These 
times display the differences between the multi-tasking total time and the single-tasking total time, as well as 
how much longer the multi-tasking tasks took. Open Photoshop was the most demanding performance test. The 
HDDs took nearly 3 seconds longer in the multi-tasking tests than in the single-tasking tests. For this same 
comparison, the performance penalty for the SSDs was much smaller—the Open Photoshop task took just under 
a third of a second longer in the multi-tasking test than in the single-tasking test. Total task time for the multi-
tasking test was 3.62 seconds longer than for the single-tasking test on the HDDs, a 27 percent performance hit. 
By contrast, the SSDs took only 0.6 seconds longer to carry out the four tasks in the multi-tasking test than in the 
single tasking test, a performance penalty of only 7 percent.  
 

Multi-tasking penalty 

System 
Four Seagate Savvio 15K  

SAS HDDs 
Four Intel X25-E Extreme SATA 

SSDs 

Open Photoshop  2.90 0.32 

Open a large file in Photoshop  0.57 0.13 

Rotate a large file 180 degrees  0.19 0.11 

Save a large file as a new PSD file   -0.04 0.04 

Total time for all four tasks  3.62 0.60 

Percentage difference between total 
time for single- and multi-task  

27% 7% 

Figure 3: Additional time tasks took in multi-tasking test than in single-tasking test. Results are from the same median runs shown 
in Figures 1 and 2.  

 
Appendix A gives the individual test run results. 
 

Test methodology 
Intel selected and provided the storage array, HDDs, SSDs, and workstation. Figure 4 presents the drives we 
tested, and Appendix B provides more detailed information on the storage configuration.  
 

System 
Seagate Savvio 15K SAS 

HDDs 

Intel X25-E Extreme SATA 

SSDs 

Vendor and model number Seagate ST973451SS Intel SSDsA2SH032G1GN 

Number of drives in system 4 4 

Size 73 GB 32 GB 

RPM 15,000 RPM N/A 

Type SAS 3.0 Gb/s SATA 3.0 Gb/s 

Controller 
LSI Logic MegaRAID SAS 

8888ELP RAID Controller 

LSI Logic MegaRAID SAS 

8888ELP RAID Controller 

Controller driver LSI 3.8.0.64 (08/12/2008) LSI 3.8.0.64 (08/12/2008) 

Figure 4: The drives we tested. 

Figure 5 summarizes the workstation configuration, and Appendix C provides detailed configuration information 
for that workstation, which we do not name because it is part of the anonymous test bed and not the storage 
arrays under test.  
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Test workstation 

Processors Two Quad-Core Intel Xeon X5460 processors at 3.16 GHz 

Memory 4 GB of FB-DDR2 PC5300 memory  

Internal disk One 250GB, 7200RPM Seagate ST3250410AS SATA 3.0 Gb/s drive 

NIC Broadcom NetXtreme Gigabit Ethernet 

OS Windows Vista Ultimate 32-bit edition with SP1  

Test software Adobe Photoshop CS4; Microsoft Office 2007 Enterprise Edition 

Figure 5: Test workstation configuration. 

 

Setting up the test hardware 
1. Install the LSI Logic MegaRAID SAS 8888ELP RAID controller card on the workstation. 
2. Connect the Newisys NDS-2240 enclosure to the workstation via the controller card. 

3. Install the four HDDs (or four SSDs) into the Newisys enclosure. 

Setting up the RAID (SSDs and HDDs) 
1. Enter the MegaRAID BIOS Configuration Utility. 
2. Select your adapter, and click Next. 
3. Click Configuration Wizard. 
4. Select New Configuration, and click Next. 
5. At the This is a Destructive Operation! screen, click Yes. 
6. Select Custom Configuration, and click Next. 
7. Assign all of the drives in your array to your RAID, and click Accept DG. 
8. Click Next. 
9. Click Add to SPAN. 
10. Click Next. 
11. When setting up the SSDs, set the RAID level to RAID 0, set Disk Cache to enabled, and change Select 

Size to the suggested RAID 0 size on the right for the SSDs. For the HDDs, change Select Size to the 
suggested RAID 0 size for the SSDs (118,252 MB) as well. Click Next. 

12. Click Accept. 
13. Click Yes. 
14. Click Yes. 
15. Click Home. 
16. Click Exit. 

Seasoning the drives (SSDs only) 
Note: We preconditioned the drives so that our tests would deliver accurate sustained performance values. 
Without preconditioning, tests could deliver highly variable performance. 

1. Plug in an SSD that you have securely erased or freshly performed a low-level format on. 
2. Initialize the disk, and format it as NTFS. 
3. With Iometer, run a one-second 128K sequential read test to the entire logical block addressing (LBA) 

drive space. This enables all LBAs to have some content so the SSD does not have an artificially high 
reserve space. Note: We used Iometer 2008-06-22-rc1, available from 
http://sourceforge.net/projects/iometer. 

4. Delete the IOBW.tst file from the SSD drive. 
5. With Iometer, run a 5,700-second 128K sequential read test (request size aligned on 4K sector 

boundaries) on 100 percent of the drive. This preconditions the drive.  

Formatting the drive array with Diskpart (SSDs and HDDs) 
1. Open a command prompt. 

2. Type cd c:\windows\system32 

3. Type diskpart.exe 

4. Type List Disk to determine the name of your RAID array. 

http://sourceforge.net/projects/iometer
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5. Type Select Disk # where Disk # is the name of your RAID array. 

6. Type Create partition primary align=4 

7. Type Assign Letter=E to assign this new partition the letter E. 

8. Type Exit 

9. In Windows, click Start, right-click My Computer, and select Manage. 
10. Click Disk Management. 
11. Right-click the partition, and select Format. 
12. Name the partition according to what kind of drives you are using, and format the drives as NTFS. 

Installing Windows Vista Ultimate 32-bit edition with SP1 on the internal workstation 
drive 

1. Boot to Windows Vista Ultimate with SP 1 DVD. 
2. When the installer prompts you to press any key to boot from CD or DVD, press any key. It may take 

several minutes for Windows setup to load. 
3. At the Language, time, and keyboard preference screen, accept the default options, and click Next. 
4. Click Install now. 
5. Enter the product key, and click Next. 
6. Check I accept the license terms, and click Next. 
7. At the type of installation screen, select Custom (advanced). 
8. Click Drive options (advanced). 
9. Select the destination disk for the operating system. 
10. Click Format. 
11. At the All data stored will be permanently deleted dialog, click OK. 
12. Once the system finishes formatting the disk, click Next. 
13. Windows begins the install process and automatically reboots the system twice.  
14. After the second reboot, fill in the Username, password, and password hint fields.  
15. Select a picture for the user account, and click Next. 
16. Fill in the computer name field, choose a desktop background, and click Next. 
17. When the option to enable Automatic Updates appears, click Ask me later. 
18. Select the correct time zone, date, and time; and click Next. 
19. At the Thank you screen, click Start. 
20. When the Windows Vista Ultimate with Service Pack 1 installation completes, log into Windows, and 

close the Welcome Center Dialog. 

Installing Adobe Photoshop CS4 on the external drives in the enclosure 
1. Double-click setup.exe. 
2. Click I want to Install and use Adobe Photoshop CS4 on a trial basis, and click next. 
3. At the Adobe Photoshop CS4 Install-License screen, click Accept. 
4. Click Change… under Installation Location, and set the Installation Location to E:\Photoshop. 
5. Click Install. 
6. After installation completes, click Exit. 

Copying the test files onto the test drives 
1. Copy the 119MB Photoshop PSD test file onto the E: drive. 
2. Copy the 814MB ZIP self-extracting executable onto the E: drive. 

Installing Microsoft Office 2007 Enterprise Edition on the internal drive using the 
default installation 

1. Insert the Microsoft Office Enterprise 2007 DVD. 
2. At the AutoPlay dialog box, click Run setup.exe. 
3. After setup loads, click Install Now. 
4. After installation completes, click Close. 
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Running the test 
We followed the steps in this section to run the single-tasking and multi-tasking tests on the SSDs and HDDs. 
 
As part of the test procedure, we deleted the contents of the C:\Windows\Prefetch folder before each run. This 
creates a more consistent test as it resets the Windows Superfetch cache. We also simulated normal use by 
opening and closing several applications before starting the timed tasks for the single-tasking tests.  

Single-tasking version 
1. Restart the workstation. 
2. After the system has booted up, start a stopwatch timer. 
3. Open the C:\Windows\Prefetch Folder, and delete the contents. 
4. When the timer reaches 2 minutes, open and close the following programs to simulate normal usage: 

Microsoft Excel, Microsoft Word, Microsoft PowerPoint, Windows Media Player, and Microsoft Outlook. 
5. Prepare to extract the ZIP file by double-clicking the extracting EXE. 
6. Set the ZIP file to extract to the external drives. 
7. Extract the large ZIP file onto the external drives. 
8. After the unzipping process completes, open Photoshop. Time how long it takes Photoshop to open to a 

blank screen. 
9. When Photoshop finishes opening, click File->Open, open the Photoshop PSD test file, and time how 

long it takes the image to fully appear on the screen. 
10. Rotate the image 180 degrees by clicking Image->Image Rotation->180. Time how long it takes the 

image to rotate. 
11. Save the image as a new PSD on the external drives by clicking File->Save as.  

12. Name the file test1, test2, or test3, depending on the run number. 

13. At the Photoshop Format Options window, click OK, and time how long it takes to save the image. 
14. Close Photoshop. 
15. Repeat steps 1 through 14, for a total of three test runs. 

Multi-tasking version 
1. Restart the workstation. 
2. After the system has booted up, start timing. 
3. Open the C:\Windows\Prefetch Folder, and delete the contents. 
4. Prepare to extract the ZIP file by double-clicking the extracting EXE. 
5. Set the ZIP file to extract to the external drives. 
6. When the timer reaches 2 minutes, start a second timer, and begin extracting the large ZIP file onto the 

external drives. 
7. When the second timer reaches 15 seconds, open Photoshop. Time how long it takes Photoshop to 

open to a blank screen. 
8. When Photoshop finishes opening, click File->Open, open the Photoshop PSD test file, and time how 

long it takes the image to fully appear on the screen. 
9. Rotate the image 180 degrees by clicking Image->Image Rotation->180. Time how long it takes the 

image to rotate. 
10. Save the image as a new PSD on the external drives by clicking File->Save as.  

11. Name the file test1, test2, or test3, depending on the run number. 

12. At the Photoshop Format Options window, click OK, and time how long it takes to save the image. 
13. Close Photoshop. 
14. Wait for the unzipping process to complete, and stop your second timer. 
15. Repeat steps 1 through 14, for a total of three test runs. 
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Appendix A: Test results 
Figure 6 lists test results for the three runs of the single-tasking and multi-tasking versions of the test on the two 
test configurations. 
 

Single-tasking 

Run 1 
Four Seagate Savvio 

15K SAS HDDs 
Four Intel X25-E 

Extreme SATA SSDs 
Percentage win for 

SSDs 

Open Photoshop 8.66 4.81 44.50% 

Open a large file in Photoshop 1.83 1.40 23.50% 

Rotate a large image 180 degrees 1.32 1.24 6.10% 

Save a large file as a new PSD file 1.49 1.38 7.40% 

Total time 13.30 8.83 33.60% 

Run 2 
Four Seagate Savvio 

15K SAS HDDs 
Four Intel X25-E 

Extreme SATA SSDs 
Percentage win for 

SSDs 

Open Photoshop 8.72 5.01 42.50% 

Open a large file in Photoshop 2.02 1.37 32.20% 

Rotate a large image 180 degrees 1.25 1.18 5.60% 

Save a large file as a new PSD file 1.51 1.37 9.90% 

Total time 13.50 8.93 33.90% 

Run 3 
Four Seagate Savvio 

15K SAS HDDs 
Four Intel X25-E 

Extreme SATA SSDs 
Percentage win for 

SSDs 

Open Photoshop 8.96 4.87 45.60% 

Open a large file in Photoshop 1.82 1.63 10.40% 

Rotate a large image 180 degrees 1.36 1.30 4.40% 

Save a large file as a new PSD file 1.50 1.43 4.70% 

Total time 13.64 9.23 32.30% 

Multi-tasking 

Run 1 
Four Seagate Savvio 

15K SAS HDDs 
Four Intel X25-E 

Extreme SATA SSDs 
Percentage win for 

SSDs 

Open Photoshop 10.63 5.33 49.90% 

Open a large file in Photoshop 2.91 1.50 48.50% 

Rotate a large image 180 degrees 1.53 1.29 15.70% 

Save a large file as a new PSD file 1.46 1.41 3.40% 

Total time for Photoshop tasks 16.53 9.53 42.30% 

Concurrent unzip of other large file 148.91 122.75 17.60% 

Run 2 
Four Seagate Savvio 

15K SAS HDDs 
Four Intel X25-E 

Extreme SATA SSDs 
Percentage win for 

SSDs 

Open Photoshop 11.62 5.47 52.90% 

Open a large file in Photoshop 2.59 1.36 47.50% 

Rotate a large image 180 degrees 1.44 1.19 17.40% 

Save a large file as a new PSD file 1.47 1.28 12.90% 

Total time for Photoshop tasks 17.12 9.30 45.70% 

Concurrent unzip of other large file 148.89 121.88 18.10% 
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Multi-tasking 

Run 3 
Four Seagate Savvio 

15K SAS HDDs 
Four Intel X25-E 

Extreme SATA SSDs 
Percentage win for 

SSDs 

Open Photoshop 11.15 5.67 49.10% 

Open a large file in Photoshop 3.00 1.76 41.30% 

Rotate a large image 180 degrees 1.71 1.19 30.40% 

Save a large file as a new PSD file 1.45 1.39 4.10% 

Total time for Photoshop tasks 17.31 10.01 42.20% 

Concurrent unzip of other large file 150.84 123.96 17.80% 

Figure 6: Results for the single-tasking and multi-tasking tests. We calculate percentage wins with the following formula: 1-SSD 
result/HDD result. 
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Appendix B: Storage configuration 
Figure 7 shows the storage hardware.  
 

System 
Four Seagate Savvio  

15K SAS HDDs 
Four Intel X25-E 

Extreme SATA SSDs 

Storage connectivity (fibre channel, SAS, SATA, iSCSI) SAS SATA 

Storage model and OS/firmware revision Newisys NDS-2240 Newisys NDS-2240 

Number of storage controllers 1 1 

HBA model and firmware 
MegaRAID SAS 
8888ELP 1.40.02-0514 

MegaRAID SAS 
8888ELP 1.40.02-0514 

Number of HBAs/host 1 1 

Total number of drives we tested in solution 4 4 

Figure 7: Primary storage hardware. 

 
Figure 8 shows the storage drive configuration.  
 

System 
Four Seagate Savvio  

15K SAS HDDs 
Four Intel X25-E  

Extreme SATA SSDs 

Drive type, speed   SAS, 15K RPM   SSD 

Firmware   SM04   8620 

Raw capacity per drive   73 GB   32 GB 

Number of physical drives in test   4   4 

Total raw storage capacity   292   128 

RAID level   RAID 0   RAID 0 

Total formatted capacity   118,252 MB*   118,252 MB 

  Figure 8: Primary storage drive configuration. 

 *Before we formatted the HDDs, we short-stroked the drives to have the same amount of space as four SSDs in a 

RAID 0. 
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Appendix C: Test environment 
Figure 9 describes the test workstation. 
 

Test workstation 

General  

Number of processor packages 2 

Number of cores per processor package 4 

Number of hardware threads per core 4 

System Power Management Policy Balanced 

CPU  

Vendor Intel  

Name Xeon X5460 

Stepping 6 

Socket type Socket 771-LGA 

Core frequency (GHz) 3.16 

Front-side bus frequency (MHz) 1,333 

L1 cache 32 KB + 32 KB (per core) 

L2 cache 12 MB (2 x 6 MB shared) 

Platform  

Motherboard model number HP 0A98h 

Motherboard chipset Intel 5400B 

Motherboard revision number C0 

BIOS name and version Hewlett-Packard 786F5 v01.27 (08/08/2008) 

BIOS settings Default 

Chipset INF driver Intel 8.5.0.1009 

Memory module(s)  

Vendor and model number ELPIDA EBE21FD4AJFT-6E-E 

Type FB-DDR2 PC-5300 

Speed (MHz) 667  

Speed in the system currently running @ (MHz) 667  

Timing/latency (tCL-tRCD-iRP-tRASmin) 5-5-5-15 

Size (MB) 4,096  

Number of RAM modules 2 x 2,048 MB 

Chip organization Double-sided 

Channel Dual 

Hard disk  

Vendor and model number Seagate ST3250410AS 

Number of disks in system 1 

Size (GB) 250  

Buffer size (MB) 16  

RPM 7,200  

Type SATA 3.0 Gb/s 

Controller Intel 6321ESB 

Controller driver Intel 8.2.0.1011 (10/15/2006) 
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Test workstation 

Operating system  

Name Windows Vista Ultimate 32-bit edition 

Build number 6001 

Service Pack SP1 

File system NTFS 

Language English 

Microsoft DirectX version 9.0c 

Graphics  

Vendor and model number NVidia Quadro FX3700 

Chipset NVidia Quadro 

BIOS Version 62.92.27.00.13 

Type  PCI-E 

Memory size (MB) 512 

Resolution 1,024 x 768 x 32-bit 

Driver Microsoft 6.0.6001.18000 (6/21/2006) 

Network card/subsystem  

Vendor and model number Broadcom NetXtreme Gigabit Ethernet 

Type Integrated 

Driver 10.100.0.0 (7/25/2008) 

Optical drive  

Vendor and model number HL-DT-ST DVD-RAM GH15L 

Type CD/DVD-ROM 

Interface SATA 

Dual/single layer Dual 

USB ports  

Number of ports 7 

Type of ports (USB 1.1, USB 2.0) 2.0 

Figure 9: Detailed system configuration information for the test workstation. 
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About Principled Technologies 
We provide industry-leading technology assessment and fact-based marketing services. We bring to every 
assignment extensive experience with and expertise in all aspects of technology testing and analysis, from 
researching new technologies, to developing new methodologies, to testing with existing and new tools.  
When the assessment is complete, we know how to present the results to a broad range of target audiences. We 
provide our clients with the materials they need, from market-focused data to use in their own collateral to 
custom sales aids, such as test reports, performance assessments, and white papers. Every document reflects 
the results of our trusted independent analysis.  
 
We provide customized services that focus on our clients’ individual requirements. Whether the technology 
involves hardware, software, Web sites, or services, we offer the experience, expertise, and tools to help you 
assess how it will fare against its competition, its performance, whether it’s ready to go to market, and its quality 
and reliability. 
 
Our founders, Mark L. Van Name and Bill Catchings, have worked together in technology assessment for over 
20 years. As journalists, they published over a thousand articles on a wide array of technology subjects. They 
created and led the Ziff-Davis Benchmark Operation, which developed such industry-standard benchmarks as 
Ziff Davis Media’s Winstone and WebBench. They founded and led eTesting Labs, and after the acquisition of 
that company by Lionbridge Technologies were the head and CTO of VeriTest. 
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